Nouveautés dans QGIS 2.0

Veuillez noter que cette version est un jalon important dans la série des versions. Comme tel, elle intègre de nouvelles fonctionnalités et étend l’interface de programmation par rapport à la version QGIS 1.8.0. Nous recommandons d’utiliser cette version préférentiellement aux précédentes.

This release includes hundreds of bug fixes and many new features and enhancements that will be described in this manual. Also compare with the visual changelog at http://changelog.linfiniti.com/qgis/version/200/

Interface utilisateur

  • New icon theme: We have updated our icon theme to use the ‘GIS’ theme introducing an improved level of consistency and professionalism to the QGIS user interface.
  • Onglets latéraux, groupes dépliables: Nous avons standardisé la disposition des onglets et introduit des zones de groupe dépliables dans bon nombre de nos boîtes de dialogue afin de faciliter la navigation dans les différentes options et offrir un meilleur usage de l’écran.

  • Soft notifications: In many cases we want to tell you something, but we don’t want to stop your work or get in your way. With the new notification system QGIS can let you know about important information via a message bar (colour depends on the importance of the message) that appears at the top of the map canvas but doesn’t force you to deal with it if you are busy doing something else. Programmers can create these notification (e.g. from a plugin) to using our python API.
  • Application custom font and Qt stylesheet: The system font used for the application’s user interface can now be set. Any C++ or Python plugin that is a child of the QGIS GUI application or has copied/applied the application’s GUI stylesheet can inherit its styling, which is useful for GUI fixes across platforms and when using custom QGIS Qt widgets, like QgsCollapsibleGroupBox.
  • Live color chooser dialogs and buttons: Every color chooser button throughout the interface has been updated to give visual feedback on whether the current color has a transparent, or ‘alpha,’ component. The color chooser opened by the new color buttons will now always be the default for the operating system. If the user has Use live-updating color chooser dialogs checked under Options -> General -> Application , any change in the color chooser will immediately be shown in the color button and for any item currently being edited, where applicable.
  • Annotations SVG : Avec QGIS 2.0, vous pouvez maintenant ajouter des annotations SVG à votre carte, soit en les plaçant à un endroit spécifique dans la fenêtre, soit à une position géographique définie.

Fournisseur de données

  • Gestion d’Oracle Spatial : QGIS 2.0 inclut maintenant la gestion d’Oracle Spatial.

  • Web Coverage Service provider added: QGIS now provides native support for Web Coverage Service layers - the process for adding WCS is similar to adding a WMS layer or WFS layer.
  • Raster Data Provider overhaul: The raster data provider system has been completely overhauled. One of the best new features stemming from this work is the ability to Layer -> Save As... to save any raster layer as a new layer. In the process you can clip, resample, and reproject the layer to a new Coordinate Reference System. You can also save a raster layer as a rendered image so if you for example have single band raster that you have applied a colour palette to, you can save the rendered layer out to a georeferenced RGB layer.
  • Raster 2% cumulative cut by default: Many raster imagery products have a large number of outliers which result in images having a washed out appearance. QGIS 2.0 intoduces much more fine grained control over the rendering behaviour of rasters, including using a 2% - 98% percent cumulative cut by default when determining the colour space for the image.
  • WMS identify format: It is now possible to select the format of the identify tool result for WMS layers if multiple known formats are supported by the server. The supported formats are HTML, feature (GML) and plain text. If the feature (GML) format is selected, the result is in the same form as for vector layers, the geometry may be highlighted and the feature including attributes and geometry may be copied to clipboard and pasted to another layer.
  • WMTS Support: The WMS client in QGIS now supports WMTS (Web Mapping Tile Service) including selection of sub-datasets such as time slices. When adding a WMS layer from a compliant server, you will be prompted to select the time slice to display.

Style

  • Propriétés définies par les données : Avec cette nouvelle fonctionnalité, il est possible de contrôler le type de symbole, la taille, la couleur, la rotation et beaucoup d’autres propriétés par les données attributaires.

  • Amélioration de la gestion des couches de symboles : Le nouveau mode d’affichage des couches de symboles sous forme d’arbre hiérarchique, permet d’accéder facilement et rapidement à toutes les couches de symboles.

  • Support for transparency in colour definitions: In most places where you select colours, QGIS now allows you to specify the alpha channel (which determins how transparent the colour should be). This allows you to create great looking maps and to hide data easily that you don’t want users to see.
  • Color Control for Raster Layers: QGIS 2.0 allows you to precisely control exactly how you’d like raster layers to appear. You now have complete control over the brightness, contrast and saturation of raster layers. There’s even options to allow display of rasters in grayscale or by colorising with a specified color.
  • Copie du style entre plusieurs couches : Il est maintenant très facile de copier le style d’une couche et l’appliquer à une autre. Si vous travaillez sur des couches de même type, il suffit d’un simple clic-droit puis un clic sur Copier le style puis un nouveau clic-droit sur une autre couche et enfin un clic sur Coller le style.

  • Sauvegardez les styles dans votre base de données : Si vous utilisez une base de données pour stocker vos couches vecteurs, vous pouvez maintenant y stocker directement les styles de chaque couche. Cela permet de partager facilement des couches et leur style dans un environnement multi-utilisateurs tel qu’une entreprise.

  • Colour ramp support: Colour ramps are now available in many places in QGIS symbology settings and QGIS ships with a rich, extensible set of colour ramps. You can also design your own and many cpt-city themes are included in QGIS now ‘out of the box’. Color ramps even have full support for transparency!
  • Set custom default styles for all layer types: Now QGIS lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them.

Composeur de cartes

  • Éléments de carte HTML: Vous pouvez maintenant placer des éléments en html sur vos cartes.

  • Lignes d’accrochage automatique: avoir les éléments bien alignés sur la carte est primordial pour réaliser de belles cartes imprimées. Des lignes d’accrochage automatique ont été ajoutées pour permettre d’aligner facilement les objets entre eux, en glissant simplement un objet près d’un autre.

  • Lignes d’accrochage manuel: Parfois, vous avez besoin d’aligner des objets à certains endroits du composeur. Avec les nouvelles lignes d’accrochage manuel, vous pouvez ajouter des lignes d’accrochage vous permettant d’aligner les objets. Il suffit de cliquer et glisser depuis la règle en haut ou à droite de la fenêtre pour ajouter une nouvelle ligne de repère.

  • Génération de cartes en série. N’avez-vous jamais eu besoin de créer une série de cartes ? Bien sûr que si ! Le composeur dispose maintenant d’un outil pour générer des atlas. La couche utilisée pour déterminer l’emprise des cartes peut être une couche de points, lignes ou polygones et les attributs de cette couche peuvent être utilisés pour générer des zones de texte adaptées à chaque carte d’une série.

  • Gestion de plusieurs pages : un composeur peut maintenant comporter plusieurs pages.

  • Expressions dans les étiquettes du composeur: L’étiquette du composeur dans la version 1.8 était quelque peu limitée et n’autorisait l’utilisation que de la seule variable $CURRENT_DATE. Dans la version 2.0, le support d’expression est plus complète et offre plus de puissance et de contrôle des étiquettes finales.

  • Automatic overview support in map frame: Need to show the current area of the main map frame in a smaller overview window. Now you can. The map frame now contains the ability to show the extents of other and will update when moved. Using this with the atlas generation feature now core in the composer allows for some slick map generation. Overview frame style uses the same styling as a normal map polygon object so your creativity is never restricted.
  • Layer blending: Layer blending makes it possible to combine layers in new and exciting ways. While in older versions, all you could do was to make the layer transparent, you can now choose between much more advanced options such as “multiply”, “darken only”, and many more. Blending can be used in the normal map view as well as in print composer. For a short tutorial on how to use blending in print composer to make the most out of background images, see “Vintage map design using QGIS”.
  • Support d’étiquettes HTML: Le support HTML a été ajouté aux étiquettes du composeur de cartes afin de vous offrir plus de contrôle sur vos cartes finales. Les étiquettes HTML supportent pleinement les feuilles de style css, html, et même javascript si c’est ce qui vous enchante.

  • Multicolumn composer legend: The composer legend now supports multiple columns. Splitting of a single layer with many classes into multiple columns is optional. Single symbol layers are now added by default as single line item. Three different styles may be assigned to layer/group title: Group, Subgroup or Hidden. Title styles allow arbitrary visual grouping of items. For example, a single symbol layer may be displayed as single line item or with layer title (like in 1.8), symbols from multiple following layers may be grouped into a single group (hiding titles) etc. Feature counts may be added to labels.
  • Mise à jour du gestionnaire de composeurs : Les améliorations suivantes ont été réalisées sur le gestionnaire de composeurs :

    • Le nom d’un composeur de carte peut être choisi au moment de sa création

    • Les composeurs de carte peuvent maintenant être dupliqués

    • Nouveau depuis un modèle et depuis un Spécifique (dans le gestionnaire de composition) permet de créer un composeur à partir d’un modèle situé n’importe où sur le système de fichiers.

    • Le projet peut maintenant être sauvegardé directement depuis la fenêtre du composeur d’impression

    • Toutes les commandes de gestion des composeurs sont directement accessibles depuis la fenêtre du composeur

Étiquetage

  • New labeling system: The labeling system has been totally overhauled - it now includes many new features such as drop shadows, ‘highway shields’, many more data bound options, and various performance enhancements. We are slowly doing away with the ‘old labels’ system, although you will still find that functionality available for this release, you should expect that it will disappear in a follow up release.
  • Étiquette basée sur une formule: Toute la puissance de l’étiquetage normal et des règles de formule peut maintenant être utilisée dans les propriétés d’étiquetage. Presque toutes les propriétés peuvent être définies avec une expression ou une valeur de champ, vous permettant ainsi d’avoir plus de contrôle sur le rendu d’étiquette. Les formules peuvent porter sur un champ (par exemple, définir la taille de la police de caractères avec la valeur du champ ‘police’) ou être plus complexes.

  • Older labeling engine deprecated: Use of the older labeling engine available in QGIS <= 1.8 is now discouraged (i.e. deprecated), but has not been removed. This is to allow users to migrate existing projects from the old to new labeling engine. The following guidelines for working with the older engine in QGIS 2.0 apply:
    • Deprecated labeling tab is removed from vector layer properties dialog for new projects or older opened projects that don’t use that labeling engine.
    • Deprecated tab remains active for older opened projects, if any layer uses them, and does not go away even if saving the project with no layers having the older labeling engine enabled.
    • Deprecated labeling tab can be enabled/disabled for the current project, via Python console commands. Please note: There is a very high likelihood the deprecated labelling engine will be completely removed prior to the next stable release of QGIS. Please migrate older projects.

Programmation

  • New Python Console: The new Python console gives you even more power. Now the with auto complete support, syntax highlighting, adjustable font settings. The side code editor allows for easier entry of larger blocks of code with the ability to open and run any Python file in the QGIS session.
  • Even more expression functions: With the expression engine being used more and more though out QGIS to allow for things like expression based labels and symbol, many more functions have been added to the expression builder and are all accessible through the expression builder. All functions include comprehensive help and usage guides for ease of use.
  • Custom expression functions: If the expression engine doesn’t have the function that you need. Not to worry. New functions can be added via a plugin using a simple Python API.
  • New cleaner Python API: The Python API has been revamped to allow for a more cleaner, more pythonic, programming experience. The QGIS 2.0 API uses SIP V2 which removes the messy toString(), toInt() logic that was needed when working with values. Types are now converted into native Python types making for a much nicer API. Attributes access is now done on the feature itself using a simple key lookup, no more index lookup and attribute maps.
  • Code compatibility with version 1.x releases: As this is a major release, it is not completely API compatible with previous 1.x releases. In most cases porting your code should be fairly straightforward - you can use this guide to get started. Please use the developer mailing list if you need further help.
  • Python project macros: A Python module, saved into a project.qgs file, can be loaded and have specific functions run on the following project events: openProject(), saveProject() and closeProject(). Whether the macros are run can be configured in the application options.

Outils d’analyse

  • Processing Commander: For quick access to geoprocessing functionality, just launch the processing commander (Ctrl + Alt + M) and start typing the name of the tool you are looking for. Commander will show you the available options and launch them for you. No more searching through menus to find tools. They are now right at your fingertips.
  • Améliorations de l’extension Cartes de chaleur : cette extension a subit de nombreuses améliorations et optimisations rendant la création de cartes de chaleur beaucoup plus rapide. De plus, vous avez maintenant le choix dans la fonction kernel à utiliser.

  • Processing Support: The SEXTANTE project has been ported to and incorporated into QGIS as core functionality. SEXTANTE has been renamed to ‘Processing’ and introduces a new menu in QGIS from where you can access a rich toolbox of spatial analysis tools. The processing toolbox has incredibly rich functionality - with a python programming API allowing you to easily add new tools, and hooks to provide access to analysis capabilities of many popular open source tools such as GRASS, OTB, SAGA etc.
  • Processing Modeller: One of the great features of the new processing framework is the ability to combine the tools graphically. Using the Processing Modeller, you can build up complex analysis from a series of small single purpose modules. You can save these models and then use them as building blocks in even more complex models. Awesome power integrated right into QGIS and very easy to use!

Extensions

  • Revamped plugin manager: In QGIS 1.x managing plugins was somewhat confusing with two interfaces - one for managing already installed plugins and one for fetching python plugins from an only plugin repository. In QGIS 2.0 we introduce a new, unified, plugin manager which provides a one stop shop for downloading, enabling/disabling and generally managing you plugins. Oh, and the user interface is gorgeous too with side tabs and easy to recognise icons!
  • Application and Project Options: Define default startup project and project templates. With QGIS 2.0 you can specify what QGIS should do when it starts: New Project (legacy behaviour, starts with a blank project), Most recent (when you start QGIS it will load the last project you worked on), Specific (always load a specific project when QGIS starts). You can use the project template directory to specify where your template projects should be stored. Any project that you store in that directory will be available for use as a template when invoking the Project ‣ New from template menu.
  • System environment variables: Current system environment variables can now be viewed and many configured within the application Options dialog. Useful for platforms, such as Mac, where a GUI application does not necessarily inherit the user’s shell environment. Also useful for setting/viewing environment variables for the external tool sets controlled by the processing toolbox, e.g. SAGA, GRASS; and, for turning on debugging output for specific sections of the source code.
  • User-defined zoom scales: A listing of zoom scales can now be configured for the application and optionally overridden per project. The list will show up in the Scale popup combo box in the main window status bar, allowing for quick access to known scales for efficiently viewing and working with the current data sources. Defined scales can be exported to an XML file that can be imported into other projects or another QGIS application.

Général

  • Quantum GIS porte maintenant le nom ‘ |qg| ‘ : ‘Quantum’ dans ‘Quantum GIS’ n’a jamais vraiment eu de sens et le fait de se référer au logiciel à la fois par Quantum GIS et QGIS était source de confusion. Nous sommes en train de passer en revue tout le projet pour remplacer Quantum GIS par QGIS (tout en majuscule). Nous allons mettre à jour tout notre code et autres documents.

Légende des couches

  • Options et comportement de la liste des couches

    • Compte total des entités d’une couche ainsi que par type de symbol

    • Les couches vectorielles en mode édition sont matérialisées par un crayon rouge lorsque des modifications n’ont pas encore été enregistrées

    • La couche active est maintenant soulignée notamment pour l’indiquer lors d’une sélection de plusieurs couches

    • Cliquer dans le blanc de la liste des couches, désélectionne maintenant les couches sélectionnées

    • Right-clicks are now treated as left-clicks prior to showing the contextual menu, allowing for one click instead of two
    • Les noms des couches et des groupes peuvent maintenant apparaitre en gras.

    • La création d’icônes de prévisualisation pour les couches raster dans la légende peut être désactivée, pour les projets où cette opération est longue

  • Dupliquer une couche existante : Dupliquer la couche vecteur ou raster sélectionnée dans la légende. Revient à importer la même couche une deuxième fois puis copier / coller le style d’une couche à l’autre.

  • Multi-layer toggle editing commands: User can now select multiple layers in legend and, if any of those are vector layers in edit mode, choose to save, rollback, or cancel current uncommitted edits. User can also choose to apply those actions across all layers, regardless of selection.

Explorateur

  • Amélioration dans le panneau Explorateur :

    • Les répertoires peuvent être filtrés par des wilcard ou des expressions régulières

    • Répertoire Nouveau projet (répertoire parent du projet actuel)

    • Propriétés de visualisation du répertoire sélectionné dans la boîte de dialogue

    • Choisir quels répertoires à scanner rapidement

    • Choisir d’ajouter un répertoire directement aux Favoris via la boîte de dialogue de navigation du système de fichiers

    • Nouveau /Volumes sur Mac (répertoire caché pour l’accès aux disques externes)

    • Nouveau groupe OWS (regroupement des connexions disponibles de serveur carto)

    • Ouvrir un deuxième explorateur (Vue -> Panneaux -> navigateur (2)) : permet d’utiliser le glisser-déposer entre les deux explorateurs

    • Icons now sorted by item group type (filesystem, databases, map servers)
    • Les propriétés des couches ont maintenant un meilleur rendu